1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. You are viewing our forum as a guest. For full access please Register. WindowsBBS.com is completely free, paid for by advertisers and donations.

Resolved Dell Wireless Kyboard & mouse combo KM632

Discussion in 'Mobile Devices' started by kirkfonseca, 2013/09/23.

  1. 2013/09/23
    kirkfonseca

    kirkfonseca Inactive Thread Starter

    Joined:
    2010/03/03
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    76
    Computer Experience:
    Intermediate
    Hi,
    I just bought a new Wireless Keyboard & Mouse combo:
    Dell KM632.
    (both work on one USB )
    Problem : The mouse keeps sticking. Either too slow or too fast. Even when i click an icon or folder it does not open. have to do it 2-3 times.

    Tried changing the speed from the Control Panel> Mouse Settings.
    Still didnt work.
    Tried looking for drivers, there is only one for the "Caps Lock ". So not sure if that would help the mouse. http://www.dell.com/support/drivers...dio-xps-9100?driverId=54XRP&fileid=2987716544

    Also tried using it without a mouse pad & with it. still nothing.
    Have also had the vendor I bought it from, replace it with another item.
    still the same.
    Also tried switching USB ports.
    Tried right clicking on My Computer> Hardware>Properties>Device Hardware>
    Mouse> update drivers.

    Now i'm all out of options.
    If someone could shed some light on this would be much appreciated.
    the old mouse which was cheaper works better than this.
    Old mouse:mircrosoft mobile mouse1000.

    Thank you.

    Dell Laptop inspiron N5110,
    Win 7, ultimate.
    core- i5, 230 ghz. 64-bit
    8Gb ram, NVDIA Graphics card GE Force 525M,
    150gb hard drive,
    DVD writer
     
  2. 2013/09/23
    retiredlearner

    retiredlearner SuperGeek WindowsBBS Team Member

    Joined:
    2004/06/25
    Messages:
    5,466
    Likes Received:
    295
    Trophy Points:
    1,093
    Location:
    New Zealand
    Computer Experience:
    intermediate
    Hi kirkfonseca, Welcome to Windowsbbs. :)

    Have you uninstalled Mouse in Device Manager or previous Drivers? Neil.
     

  3. to hide this advert.

  4. 2013/10/04
    kirkfonseca

    kirkfonseca Inactive Thread Starter

    Joined:
    2010/03/03
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    76
    Computer Experience:
    Intermediate
    Sorry for the late reply. I thought I would receive an email saying that someone has replied to my post.

    Yes I did uninstall the drivers. But it still did not work.
    Thank you for your reply though, appreciate.
    I think what I will do now is just return both to the vendor.
     

Share This Page