Windows, Operating System, Security, Networking, Malware, Support, Forum, Help Site Check Our Facebook Page!
Notices
Windows Vista Post your Windows Vista related questions here.


Register your FREE account to unlock additional features at WindowsBBS.com
   
 
 
LinkBack Thread Tools
Old 18th September 2010   #1
Geek Member
THREAD STARTER
 
Profile:
Join Date: Jul 2004
Location: New York, USA
Posts: 553
Computer Experience:
Intermediate
Frank D Reputation LevelFrank D Reputation Level

My System
Unhappy

Can't connect to Internet; can't enable Windows Firewall, etc.


I'm trying to help a friend with a 3-year old Windows Vista (32-bit), Home Edition, HP laptop. Her main problem is that she can't access the Internet, but there are other errors associated with it. Here is her summary:

Note: Actual error messages are underlined to spot more easily.
Cannot access the internet either via a wireless network or wired up via an ethernet cable. The problem occurred suddenly. It was fine Wednesday morning when I checked my email, but when I booted up in the evening I could not connect to the Internet.


When I place my cursor over the "connected" icon in the tray that shows available networks (looks like two monitors and usually has a globe on it when you are connected to the internet), it says "connection status unknown. The Dependency Service or group failed to start"

Steps taken so far (multiple times) to try and fix the problem: 1. Went into the command prompt and entered netsh winsock reset, netsh ip reset, and sfc /scannow , and rebooted.
2. Went into the Services menu and made sure the Diagnostic Policy Service was set to Automatic. It was "stopped" and when I tried to "start" it, it told me "error 5: Access Denied". Permissions were all checked and after we attempted other things in the command prompt (I can not remember everything we did in there), I now get a different message when trying to start the service. It now says "Windows could not start the Diagnostic Policy Service on Local Computer. Error 1068: The dependency service or group failed to start"
3. Went into the Registry and made sure all the appropriate folders had full permissions.
4. Tried a system restore to a few days earlier but the restore never finished. Near the end of it I got an error saying there was an internal error and it could not be completed.
5. Noticed there was also a Windows Firewall problem and cannot start the firewall. It will not start automatically and when trying to turn on manually I receive the error "Windows Firewall settings cannot be displayed because the associated service is not running. Do you want to start the service?". I choose yes and get "Windows can not start the Firewall service".

So, I am pretty sure if I can get the Diagnostic Policy Service started it will be connected to the firewall issue and solve the connection problem. I just do not know how to start the service back up because it will not let me.

P.S. I even created a new identity with Admin power, and got the same results there also.

Note: We've researched this via Google using another computer, and tried everything we could find, but nothing worked, even things that worked for others.

A call to the Geek Squad revealed that to look at the PC would cost $70, plus a charge for whatever had to be done to correct the problem.

Can someone offer help please?

Frank D

Frank D is offline  

 

Register
to remove this ad.
 
 

Old 18th September 2010   #2
Alumni
 
rsinfo's Avatar
 
Profile:
Join Date: Dec 2005
Location: New Delhi, India
Posts: 3,290
Computer Experience:
Experienced but ! en
rsinfo Reputation Levelrsinfo Reputation Levelrsinfo Reputation Levelrsinfo Reputation Levelrsinfo Reputation Levelrsinfo Reputation Levelrsinfo Reputation Levelrsinfo Reputation Levelrsinfo Reputation Levelrsinfo Reputation Levelrsinfo Reputation Level

My System
Is the anti virus on the machine working or is it also shown as disabled ? You may have a malware.

rsinfo is offline  

Did you find this post helpful? Yes | No
Old 18th September 2010   #3
Geek Member
THREAD STARTER
 
Profile:
Join Date: Jul 2004
Location: New York, USA
Posts: 553
Computer Experience:
Intermediate
Frank D Reputation LevelFrank D Reputation Level

My System
rsinfo:

She says that "Norton 360 expired a couple months ago so I am unprotected, however I do have Malwarebytes installed and I run weekly scans with that. So far it has been clean."

I've advised her to run the built-in Windows Anti-Malware Scanner (mrt) then install and run SuperAntiSpyware (each once), then install and run Avira antivirus and keep it running, and then report back.

Note: She uses an older laptop just for e-mail and now for downloading the programs she needs to work on the problem HP laptop. She transfers files using a USB drive.

She should have more results for us in another 10 hours or so.

Frank D

P.S. Her laptop is an hp pavilion dv9408nr


Last edited by Frank D; 19th September 2010 at 00:49. Reason: Added laptop make & model
Frank D is offline  

Did you find this post helpful? Yes | No
Old 19th September 2010   #4
Inactive
 
Profile:
Join Date: Sep 2010
Location: New York
Posts: 33
Computer Experience:
Beginner
HeatherM Reputation Level

Hello. I am the friend experiencing the problem. I just became of this forum and registered so I can be available to supply any needed info. I already see so many helpful people and thank you in advance for your time. I am open to any suggestions/ideas. We have seemingly exhausted every avenue short of reinstalling the OS which I would prefer not to do unless absolutely necessary. I think if I can just get the Diagnostic Policy Service started it will solve the problem, but it will not allow me to start it. (error is in original post)

HeatherM is offline  

Did you find this post helpful? Yes | No
Old 19th September 2010   #5
Administrator
 
Admin.'s Avatar
 
Profile:
Join Date: Dec 2001
Location: 35⁰ 53'55.1" N, 14⁰ 28'37.5" E
Posts: 5,941
Computer Experience:
***
Admin. Reputation LevelAdmin. Reputation LevelAdmin. Reputation LevelAdmin. Reputation LevelAdmin. Reputation LevelAdmin. Reputation LevelAdmin. Reputation LevelAdmin. Reputation LevelAdmin. Reputation LevelAdmin. Reputation LevelAdmin. Reputation Level

My System
Hi,

Read this post, then post the requested log(s) in the Malware and Virus Removal forum.

Admin. is offline  

Did you find this post helpful? Yes | No
Old 19th September 2010   #6
Inactive
 
Profile:
Join Date: Sep 2010
Location: New York
Posts: 33
Computer Experience:
Beginner
HeatherM Reputation Level

Thank you. I just completed the scan and posted the logs in the appropriate forum. Posted the Dds log and was going to post the Attach log as a reply to enusure it all fit but it has not appeared yet. Will add the second log as soon as it shows.

HeatherM is offline  

Did you find this post helpful? Yes | No
Old 20th September 2010   #7
Staff
 
mattman's Avatar
 
Profile:
Join Date: Jun 2002
Location: Sydney, Aust
Posts: 8,204
Computer Experience:
working backwards
mattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Level


mattman is offline  

Did you find this post helpful? Yes | No
Old 20th September 2010   #8
Inactive
 
Profile:
Join Date: Sep 2010
Location: New York
Posts: 33
Computer Experience:
Beginner
HeatherM Reputation Level

Thank you for the wealth of information. I did run the SFC tool the other day. The final link you provided seems to hit the nail on the head so I will look into that, but will wait to finish the processes I am currently working on from the other thread just in case. Thanks again!!!

HeatherM is offline  

Did you find this post helpful? Yes | No
Old 20th September 2010   #9
Administrator
Microsoft MVP
 
Arie's Avatar
 
Profile:
Join Date: Dec 2001
Location: Birkirkara, Malta
Posts: 14,211
Computer Experience:
***
Arie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation Level

My System
Yes, 1st get the Malware issue sorted.

Arie is offline  

Did you find this post helpful? Yes | No
Old 21st September 2010   #10
Inactive
 
Profile:
Join Date: Sep 2010
Location: New York
Posts: 33
Computer Experience:
Beginner
HeatherM Reputation Level

OK we have ruled out any malware so that's good. I attampted a system restore but it will not completely successfully (tried in safe mode too). I will go through the links supplied above and try the recommendations tomorrow. thanks a bunch.

HeatherM is offline  

Did you find this post helpful? Yes | No
Old 21st September 2010   #11
Inactive
 
Profile:
Join Date: Sep 2010
Location: New York
Posts: 33
Computer Experience:
Beginner
HeatherM Reputation Level

OK I have followed all the instructions and still can not start the diagnostic policy service. Do you think reinstalling vista would fix the problem? I would hate to do that if it wont work, but if it will definitely do so, I would not hesitate.

HeatherM is offline  

Did you find this post helpful? Yes | No
Old 21st September 2010   #12
Inactive
 
Profile:
Join Date: Sep 2010
Location: New York
Posts: 33
Computer Experience:
Beginner
HeatherM Reputation Level

Attempted a system recovery. It started then gave me the following error: error Ox4001001300001002 if the problem persists please contact HP technical support.

It rebooted and now I get "BOOTMGR is missing press ctrl+alt+del to restart" but when I do that it keeps bringing back the same message and will not reboot.


HeatherM is offline  

Did you find this post helpful? Yes | No
Old 22nd September 2010   #13
Staff
 
mattman's Avatar
 
Profile:
Join Date: Jun 2002
Location: Sydney, Aust
Posts: 8,204
Computer Experience:
working backwards
mattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Level

You will need to work with HP's system because they don't use a standard Windows installation.

These are not exactly for your system, but see if they work.
http://h10025.www1.hp.com/ewfrf/wc/d...reg_R1002_USEN
http://h10025.www1.hp.com/ewfrf/wc/d...reg_R1002_USEN


I wouldn't expect System Restore to fix the network problem and now you apparently have another (more serious?) one. Trying to repair both might be too much to ask.

Do you need to back up your data? If you don't have a backup, you could take the hard disk drive out and connect it into a desktop computer to back it up. (I suggest you get an external hard drive and back it up to that, then use that as your backup system).

I would not tear my hair out any further, just backup if necessary and use the recovery system.

If you do, go to the HP website, look up your model and get any major driver and software updates before, say, installing any Windows Service Pack.

Matt

mattman is offline  

Did you find this post helpful? Yes | No
Old 22nd September 2010   #14
Geek Member
THREAD STARTER
 
Profile:
Join Date: Jul 2004
Location: New York, USA
Posts: 553
Computer Experience:
Intermediate
Frank D Reputation LevelFrank D Reputation Level

My System
P.S. Her laptop is an hp pavilion dv9408nr

Frank D

Frank D is offline  

Did you find this post helpful? Yes | No
Old 22nd September 2010   #15
Inactive
 
Profile:
Join Date: Sep 2010
Location: New York
Posts: 33
Computer Experience:
Beginner
HeatherM Reputation Level

Thank you. I have all my important info backed up. Right now I am going to try to boot from a recovery cd so I can at least get back into windows (must fox the bootmgr missing error). then will look at HP's site to investigate other avenues of restoring my system. I tried using the system restore feature using many different restore points and it always fails. When I attempted a system recovery that is what gave me the current issue (bootmgr is missing and windows does not load). thanks everyone for the help. figers crossed.

HeatherM is offline  

Did you find this post helpful? Yes | No

Having problems with your computer? Does it crash or freeze? Is your pc slow? Our technicians can identify any issues and fix your PC quickly and reliably.

 

THIS THREAD HAS EXPIRED.

Are you having the same problem? Please post a new thread, but first you'll have to join us by Registering (FREE).



Discussion Forums
Operating Systems
Windows 8 Windows 8
Windows 7 Windows 7
Windows Vista Windows Vista
Windows XP Windows XP
Windows Server System Windows Server System
Legacy Windows OS Legacy Windows OS
Internet & Networking
Networking (Hardware & Software) Networking
Internet Explorer Internet Explorer
Microsoft Mail Microsoft Mail
Firefox, Thunderbird & SeaMonkey Firefox, Thunderbird
      & SeaMonkey

Web Applications & Cloud Web Applications & Cloud
General Internet
Security
Malware and Virus Removal Malware and Virus
     Removal

Security and Privacy Security and Privacy

Other
Other PC Software Other PC Software
Test Posts Test Posts
Hardware
PC Hardware PC Hardware
Mobile Devices Mobile Devices
Community
Introductions Introductions
General Discussions General Discussions
Site Comments & Suggestions Site Comments
      & Suggestions

News News @ WindowsBBS

Thread Tools


Find us on Facebook   Web Of Trust Rating

All times are GMT. The time now is 06:25.


Recent Discussions
PC Will Not Boot After HDDs Re-Arra.. (0)
WD External Hard Drives not recogin.. (4)
BSoD (31)
Can't get Win7 shortcuts to open in.. (13)
Changing default View Fields in Out.. (3)
Dell Studio 540 350watt psu require.. (25)
Firefox and Thunderbird Version 31... (5)
How do I check links in favorites t.. (3)
CD player application (3)
Re-starting IE8 every time I change.. (1)
Battery available (free) for Arris .. (0)
Weather station software. (11)
Windows Update Failure (3)
Any advice on an iPhone? (1)
Need digital clock for comp that I .. (4)
Sound goes AWOL (6)
Need good replacement for Wordpad i.. (2)
Eliminating setpoint32.exe error (10)
xpwin grid limited width (10)
Combining partitions w/ Disk Manage.. (4)


Donate!
Support Windows BBS!



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO
Copyright 2002 - 2013 WindowsBBS.com. All rights reserved.
FDMA Media LLC
Terms of Use, Legal Information & Privacy Policy
Page generated in 0.15569 seconds with 7 queries