Windows, Operating System, Security, Networking, Malware, Support, Forum, Help Site Check Our Facebook Page!
Notices
Windows Vista Post your Windows Vista related questions here.


Register your FREE account to unlock additional features at WindowsBBS.com
   
 
 
LinkBack Thread Tools
Old 15th February 2012   #1
Senior Member
THREAD STARTER
 
Profile:
Join Date: Sep 2009
Location: Sydney AU
Posts: 269
Computer Experience:
Experienced
pcbugfixer has a little shameless behaviour in the past

My System
Send a message via Yahoo to pcbugfixer Send a message via Skype™ to pcbugfixer
Question

"C:\Users\All Users" folder not accessible in Vista Ultimate 32bit OS


G’day Folks,

"C:\Users\All Users" folder not accessible in Vista Ultimate 32bit OS.

Seems I’m getting my share of problems lately with installation’

My current problem is one of,
--------------------------------------------------------------------------------------------
Title Bar Header:
[ Location is not available ]
Message content text:
“C:\Users\All Users refers to a location that is unavailable. it could be on a hard drive on this computer, or on a network. Check to make sure that the disk is property inserted, or that you are connected to the Internet or your network, and then try again. If it still cannot be located, the information might have been moved to a different location.”
--------------------------------------------------------------------------------------------

The Laptop Unit is a ASUS M51S series Laptop with Vista Ultimate 32bit OS.

This is what was done.
Index Note: [ (#) = Re-booted]

1. The customer inadvertently (accidentally) put the Laptop into Recovery Mode (start-up screen booted to it) believing that this was needed to be done!?, and subsequently re-installed the Vista Ultimate 32bit OS on the HDD using the defaults to do so, i.e. followed whatever prompts came up.

2. Upon receiving the Laptop and checking it, the installation seemed OK including all of the Trail-ware installations and a folder containing a copy of the original user files. - However most did not contain the correct information.

3. Checking with the customer to ensure that they had backups of all files, email’s etc., I decided to perform a new and complete re-install using the recovery option and installed the Vista Ultimate and choosing the 2 partition installation (installs 1 primary and 1 Logical partition)

4. After the installation, I checked the functionality and all seemed to be OK.

5. I then installed the customers MSO 2007 Enterprise and re-booted after the install was completed.

6. I then performed the Windows Updates with the notification option to download and choose when to install them – which I did until the 300+ updates for the OS and MSO2007 were completed !!

7. I then checked the access to the Users folder and the error message popped up denying access to the “C:\Users\All Users” folder (note the active user is a Administrator with Full Access)

8. Believing that this may only have been an interim Bug, I continued to install the other customers Application software re-booting each time and finally installed the customers BitDefender Internet Security 2012 – all of the installations went well and no issues were implied in any of them, i.e. they all installed correctly.

9. I then re-checked the access to the C:\Users\All Users folder and still had the same problem with the error message.
10. all the installed programs are correctly listed in the “All Programs” menu list and the “CustomerUserName” ( Customers Name folder under Users) is fully accessible, as are the “Default” and “Public” folders. The “Default User” is not and comes up with the correct message of “not accessible / access denied”

11. Any attempt to get help from Microsoft to troubleshoot, “Why the access to the C:\Users\All Users folder stoped after performing the Windows Updates” went around in circles with the Help Desk person sending me unrelated information for all the folders that did not have access and unrelated to the actual issue.
- other attempts to establish new users and the copy the existing user files were also useless as each new User also had the same problem, i.e. were denied access to the C:\Users\All users folder.

12. I would have thought that there was a permissions issue in the Registry or Group Policies, and if there is, I did not detect the problem.

Any help to resolve this matter, without needing to start all over again (another 39+ hours to perform the complete installation again) would be appreciated !!
- i.e. to re-establish full access to the “C:\Users\All Users” folder.

Regards
pcbugfixer (this time)


Last edited by pcbugfixer; 15th February 2012 at 02:52. Reason: typo
pcbugfixer is offline  

 

Register
to remove this ad.
 
 

Old 16th February 2012   #2
SuperGeek
Lifetime Subscription
 
MitchellCooley's Avatar
 
Profile:
Join Date: Dec 2006
Location: Wichita Falls TX
Posts: 1,090
Computer Experience:
Outdated experience
MitchellCooley Reputation LevelMitchellCooley Reputation LevelMitchellCooley Reputation LevelMitchellCooley Reputation LevelMitchellCooley Reputation LevelMitchellCooley Reputation Level

My System
Send a message via MSN to MitchellCooley
This link may shed some light as to why you're experiencing this problem.

MitchellCooley is offline  

1 out of 1 members found this post helpful. Did you find this post helpful? Yes | No
Old 16th February 2012   #3
Senior Member
THREAD STARTER
 
Profile:
Join Date: Sep 2009
Location: Sydney AU
Posts: 269
Computer Experience:
Experienced
pcbugfixer has a little shameless behaviour in the past

My System
Send a message via Yahoo to pcbugfixer Send a message via Skype™ to pcbugfixer
Exclamation

G'day MitchellCooley,

Good one for looking into the C:\ProgramData\Microsoft\Windows\StartMenu\Programs folder and what I am looking for to complete my customization of the Menu structure is there !

The obvious question now is,
1. Why did it do this, and
2. How do we correct this ? so that the original C:\Users\All Users folder opens and reveals this information ?

In the article you sent, It said the following,
"This is now getting a bit long so lets go straight to the answer ... the Startup directory I needed is now at "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup" So essentially, under Vista and Windows Server 2008 the "All Users" profile is now manifested as the C:\ProgramData directory and there are shortcuts from the C:\Users\All Users directory to the new location for compatibility reasons but in most cases you will get an Access Denied dialog box when you attempt to access the shortcuts but you will find most of what you are looking for under C:\ProgramData\Microsoft. You can also access this via C:\Users\All Users\Microsoft
I can't offer you any explanation as to why the All Users profile underwent such a change in Vista (and Windows Server 2008) but for now I have solved my challenge and have got my startup program working for all users.
I hope this helps those similarly confused ..."

This was helpful to head me of in the right direction, note that in Vista the folder is the C:\ProgramData\Microsoft\Windows\StartMenu\ folder that then gives you access to the same information that i expected from the C:\Users\All Users folder.

The info re the "C:\Users\All Users\Microsoft" folder comes up empty and is also not accessible as it cannot find the \All Users.

Anyway, this is a good result and all we now need to do is fix it

Anyone with a Gold certificate should be able to show us how - Arie to the rescue - I hope

Regards
pcbugfixer much now


Last edited by pcbugfixer; 16th February 2012 at 03:12. Reason: typo
pcbugfixer is offline  

Did you find this post helpful? Yes | No
Old 16th February 2012   #4
Staff
 
mattman's Avatar
 
Profile:
Join Date: Jun 2002
Location: Sydney, Aust
Posts: 8,204
Computer Experience:
working backwards
mattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Levelmattman Reputation Level

pcbugfixer, you will note that the All Users folder icon has a bent arrow on it. It is a redirection!

It is just the way they allowed diversion of old locations to new ones, for example. changing the Documents and Settings folder in XP to the Users folder in Vista.

You can't "fix it". It is the way they built Vista.

You have turned off the options to hide system files and folders. Check for the bent arrows on the folder icons, they are redirections. Most will say "Access Denied".

Matt

mattman is offline  

Did you find this post helpful? Yes | No
Old 16th February 2012   #5
Senior Member
THREAD STARTER
 
Profile:
Join Date: Sep 2009
Location: Sydney AU
Posts: 269
Computer Experience:
Experienced
pcbugfixer has a little shameless behaviour in the past

My System
Send a message via Yahoo to pcbugfixer Send a message via Skype™ to pcbugfixer
Exclamation

G'day Mattman,

Sorry to disappoint you, the information about the "bent arrow" is the only thing correct, i.e. "you will note that the All Users folder icon has a bent arrow on it. It is a redirection!"

However, having installed 100,s of Vista systems and running them myself on a HP Laptop and Desktop machines, the information suggested by you is wrong !

All of the current Vista Systems allow access to the C:\Users\All Users folder and allow me to then customize the Menu structure that is shown in the "All Programs" accessible from the Start Bar. The only folder that behaves the way you describe under the \Users folder is the "\Users\Default User" folder, all others under the \Users folder are fully accessible.

There are some of the items that you describe that are as you say and are no more than a manipulation of the folder (file) structure by Microsoft making us believe that Vista and Windows 7 are new systems when only the interface got a new paint job and they (Microsoft) in my opinion where stupid enough to leave the older folder structure in existence and as you say used a redirection to the new folders. One would have thought that they would have and could have hidden the old folders so that their ploy was more plausible. However these redirection ploys I am aware of and had nothing to do with the issue that I described or needed fixing.

Thanks for your input anyway, at least you added further information, but alas, I needed to correct the info you posted.

In the interim on the ASUS Laptop I have used the "C:\ProgramData\Microsoft\Windows\StartMenu\" folder pointed out in the link that "MitchellCooley" posted, to perform my customization which on all the other Vista systems I did using the C:\Users\All Users folder.

There is a way to correct this which we have not as yet found.

Regards
pcbugfixer


Last edited by pcbugfixer; 16th February 2012 at 13:40. Reason: image problem
pcbugfixer is offline  

Did you find this post helpful? Yes | No
Old 16th February 2012   #6
Administrator
Microsoft MVP
 
Arie's Avatar
 
Profile:
Join Date: Dec 2001
Location: Birkirkara, Malta
Posts: 14,211
Computer Experience:
***
Arie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation Level

My System
Originally Posted by pcbugfixer View Post
Anyone with a Gold certificate should be able to show us how - Arie to the rescue - I hope
Sorry, but Matt is (mostly) correct...

The \All Users folder is a Symlink to C:\ProgramData.

The Default User is a Symlink to C:\Users\Default. A Symlink is not accessible by a user. They are there to provide backward-compatibility for programs.

Have a look at the directory listing from the command prompt using the /a switch which shows all attributes.

Attached Images:
File Type: jpg users_dir.jpg (44.9 KB, 2 views)
Arie is offline  

Did you find this post helpful? Yes | No
Old 16th February 2012   #7
Administrator
Microsoft MVP
 
Arie's Avatar
 
Profile:
Join Date: Dec 2001
Location: Birkirkara, Malta
Posts: 14,211
Computer Experience:
***
Arie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation Level

My System
Originally Posted by pcbugfixer View Post
There are some of the items that you describe that are as you say and are no more than a manipulation of the folder (file) structure by Microsoft making us believe that Vista and Windows 7 are new systems when only the interface got a new paint job and they (Microsoft) in my opinion where stupid enough to leave the older folder structure in existence and as you say used a redirection to the new folders. One would have thought that they would have and could have hidden the old folders so that their ploy was more plausible. However these redirection ploys I am aware of and had nothing to do with the issue that I described or needed fixing.
First, the new structure is not a "ploy" to make us believe Vista/Windows 7 are new operating systems (they are, even if they would have had the old "Documents and Settings" folders).

Second, the redirects are hidden. If you choose to change the default Folder Options - Hide protected operating system files from checked to un-cheked.... yea, then you'll see these.

Arie is offline  

Did you find this post helpful? Yes | No
Old 16th February 2012   #8
Senior Member
THREAD STARTER
 
Profile:
Join Date: Sep 2009
Location: Sydney AU
Posts: 269
Computer Experience:
Experienced
pcbugfixer has a little shameless behaviour in the past

My System
Send a message via Yahoo to pcbugfixer Send a message via Skype™ to pcbugfixer
Exclamation

G'day Arie,

So what are you telling me, that his is the only installation that is correct and all the others that allow access to the C:\Users\All Users\ folder are wrong ?

Your comment of
"The "All Users" folder is a junction point. It re-directs to \Users\Default The \All Users folder is a Symlink to \ProgramData.
Have a look at the directory listing from the command prompt using the /a switch which shows all attributes."

Maybe so, however that does not negate that on other Vista installations with obviously the as you say "Second, the redirects are hidden. If you choose to change the default Folder Options - Hide protected operating system files from checked to un-cheked.... yea, then you'll see these."

- Yes it is unchecked for me to be able to see the C:\Users\All Users\ folder, to which I then have "Full" access without error messages !!

Unless we have a fix for the initial issue, I will mark this as resolved in 48 hours.

Regards
pcbugfixer

pcbugfixer is offline  

Did you find this post helpful? Yes | No
Old 16th February 2012   #9
Administrator
Microsoft MVP
 
Arie's Avatar
 
Profile:
Join Date: Dec 2001
Location: Birkirkara, Malta
Posts: 14,211
Computer Experience:
***
Arie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation Level

My System
Originally Posted by pcbugfixer View Post
G'day Arie,

So what are you telling me, that his is the only installation that is correct and all the others that allow access to the C:\Users\All Users\ folder are wrong ?
Nope, not really

Originally Posted by pcbugfixer View Post
Your comment of
"The "All Users" folder is a junction point. It re-directs to \Users\Default The \All Users folder is a Symlink to \ProgramData.
Have a look at the directory listing from the command prompt using the /a switch which shows all attributes."

Maybe so, however that does not negate that on other Vista installations with obviously the as you say "Second, the redirects are hidden. If you choose to change the default Folder Options - Hide protected operating system files from checked to un-cheked.... yea, then you'll see these."

- Yes it is unchecked for me to be able to see the C:\Users\All Users\ folder, to which I then have "Full" access without error messages !!
Go to a command prompt, change to the \Users folder and run the command dir /a.

You should see a date & time stamp for the All Users listing followed by <SYMLINKD> .All Users [C:\ProgramData

You should have "full access" (your words) to C:\Users\All Users\. Double clicking that folder will get you the view I have in the attached image.

The \Users\Default User "folder" (being a junction point) will give you an "access denied" message when trying to open.

I mixed things up in my original post, I'll edit it for the correct info.

Attached Images:
File Type: jpg all-users.jpg (37.1 KB, 9 views)
Arie is offline  

Did you find this post helpful? Yes | No
Old 17th February 2012   #10
Senior Member
THREAD STARTER
 
Profile:
Join Date: Sep 2009
Location: Sydney AU
Posts: 269
Computer Experience:
Experienced
pcbugfixer has a little shameless behaviour in the past

My System
Send a message via Yahoo to pcbugfixer Send a message via Skype™ to pcbugfixer
OK, seems we are getting somewhere Arie,

The structure at the CMD is not pointing to C: and is pointing to S: instead, don't ask me how other than a error in the installation from the recovery and electing to install the OS using 2 partitions, most likely.

Copy :
----------------------------------------------
C:\Users>dir /a
Volume in drive C is VistaOS
Volume Serial Number is 84DD-B36F

Directory of C:\Users

14/02/2012 08:16 AM <DIR> .
14/02/2012 08:16 AM <DIR> ..
03/11/2006 12:00 AM <SYMLINKD> All Users [S:\ProgramData]
26/04/2008 04:38 AM <DIR> Default
03/11/2006 12:00 AM <JUNCTION> Default User [S:\Users\Default]
10/02/2012 03:18 PM 174 desktop.ini
26/04/2008 04:38 AM <DIR> Public
17/02/2012 10:13 AM <DIR> Yxxxxx Sxxxxxx
1 File(s) 174 bytes
7 Dir(s) 101,610,225,664 bytes free

C:\Users>
----------------------------------------------
NB: Yxxxxx Sxxxxxx = name was edited.

However, I cannot find the entry in the registry to correct this and point / correct S:\ to C:\

Your help is obviously needed please to do this.

Regards
pcbugfixer

pcbugfixer is offline  

Did you find this post helpful? Yes | No
Old 17th February 2012   #11
Administrator
Microsoft MVP
 
Arie's Avatar
 
Profile:
Join Date: Dec 2001
Location: Birkirkara, Malta
Posts: 14,211
Computer Experience:
***
Arie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation Level

My System
Well, a drive S?

Anyway, you'll probably better off with either a repair install (although it could well be that a repair install doesn't fix this particular issue) or a clean install.

Check out C:\ProgramData... run a dir /a there too. Another 5 junction points. My bet is they all point to the non-existing drive S.

AFAIK you can't edit junction point data (it is NTFS data, you won't find anything in your registry). You can delete & then re-create the junction points (you'll have to find all the junction points on the system though).

Have a read here: How to create and manipulate NTFS junction points.

Arie is offline  

Did you find this post helpful? Yes | No
Old 17th February 2012   #12
Senior Member
THREAD STARTER
 
Profile:
Join Date: Sep 2009
Location: Sydney AU
Posts: 269
Computer Experience:
Experienced
pcbugfixer has a little shameless behaviour in the past

My System
Send a message via Yahoo to pcbugfixer Send a message via Skype™ to pcbugfixer
G'day Arie,

Firstly thanks for the reply and information looking good.

As to "S:" this had me wondering how it got it in the first place and as I suggested, it may have been an error in the recovery when I elected to do so with 2 partitions where it created a primary and the logical partition, i.e. had a script error ?

I am about to create an image of the current setup and then I will try to use the information of the "How to create and manipulate NTFS junction points" you sent and I will post the result when I have done so.

Having already used the "C:\ProgramData\Microsoft\Windows\StartMenu\ folder" access to customize the Menu, how will the alteration to the NTFS junction points affect this Arie ??

Regards
pcbugfixer much now


Last edited by pcbugfixer; 18th February 2012 at 00:07. Reason: Additional Info and question
pcbugfixer is offline  

Did you find this post helpful? Yes | No
Old 18th February 2012   #13
Senior Member
THREAD STARTER
 
Profile:
Join Date: Sep 2009
Location: Sydney AU
Posts: 269
Computer Experience:
Experienced
pcbugfixer has a little shameless behaviour in the past

My System
Send a message via Yahoo to pcbugfixer Send a message via Skype™ to pcbugfixer
1. Arie, Thanks for all the help.

2. The info for the editing of the edit junction point data mostly referred to Win 2000 and not vista specifically, and I must admit that I have spent too much time on this issue already, so I will not change anything at this time as the alternative to access the structure via \ProgramData. is working and will suffice to do the job.

3. I will mark this as Resolved anyway.

Regards
pcbugfixer

pcbugfixer is offline  

Did you find this post helpful? Yes | No
Old 20th February 2012   #14
Administrator
Microsoft MVP
 
Arie's Avatar
 
Profile:
Join Date: Dec 2001
Location: Birkirkara, Malta
Posts: 14,211
Computer Experience:
***
Arie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation LevelArie Reputation Level

My System
Originally Posted by pcbugfixer View Post
2. The info for the editing of the edit junction point data mostly referred to Win 2000 and not vista specifically, and I must admit that I have spent too much time on this issue already, so I will not change anything at this time as the alternative to access the structure via \ProgramData. is working and will suffice to do the job.
Nothing has changed in that regards. NTFS has had only tiny revisions since 2000.

Please note that you are going to return a 'broken' system. When certain software installations will be attempted ('legacy' or software not written properly to take Windows Vista/7 into account) errors will prevent installation.

Arie is offline  

Did you find this post helpful? Yes | No

Having problems with your computer? Does it crash or freeze? Is your pc slow? Our technicians can identify any issues and fix your PC quickly and reliably.

 

THIS THREAD HAS EXPIRED.

Are you having the same problem? Please post a new thread, but first you'll have to join us by Registering (FREE).



Discussion Forums
Operating Systems
Windows 8 Windows 8
Windows 7 Windows 7
Windows Vista Windows Vista
Windows XP Windows XP
Windows Server System Windows Server System
Legacy Windows OS Legacy Windows OS
Internet & Networking
Networking (Hardware & Software) Networking
Internet Explorer Internet Explorer
Microsoft Mail Microsoft Mail
Firefox, Thunderbird & SeaMonkey Firefox, Thunderbird
      & SeaMonkey

Web Applications & Cloud Web Applications & Cloud
General Internet
Security
Malware and Virus Removal Malware and Virus
     Removal

Security and Privacy Security and Privacy

Other
Other PC Software Other PC Software
Test Posts Test Posts
Hardware
PC Hardware PC Hardware
Mobile Devices Mobile Devices
Community
Introductions Introductions
General Discussions General Discussions
Site Comments & Suggestions Site Comments
      & Suggestions

News News @ WindowsBBS

Thread Tools


Find us on Facebook   Web Of Trust Rating

All times are GMT. The time now is 22:10.


Recent Discussions
BSoD (28)
Can't get Win7 shortcuts to open in.. (13)
Changing default View Fields in Out.. (3)
Dell Studio 540 350watt psu require.. (25)
Firefox and Thunderbird Version 31... (3)
How do I check links in favorites t.. (3)
CD player application (3)
Re-starting IE8 every time I change.. (1)
Battery available (free) for Arris .. (0)
Weather station software. (10)
Windows Update Failure (3)
Any advice on an iPhone? (1)
Need digital clock for comp that I .. (4)
Sound goes AWOL (6)
Need good replacement for Wordpad i.. (2)
Eliminating setpoint32.exe error (10)
xpwin grid limited width (10)
Combining partitions w/ Disk Manage.. (4)
Computer (XP) freezes when click on.. (9)
I moved my pictures to a 68gb thum .. (11)


Donate!
Support Windows BBS!



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO
Copyright 2002 - 2013 WindowsBBS.com. All rights reserved.
FDMA Media LLC
Terms of Use, Legal Information & Privacy Policy
Page generated in 0.22887 seconds with 8 queries