1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. You are viewing our forum as a guest. For full access please Register. WindowsBBS.com is completely free, paid for by advertisers and donations.

New site software very sluggish

Discussion in 'Site Comments & Suggestions' started by rikki, 2016/06/23.

  1. 2016/06/23
    rikki

    rikki Well-Known Member Thread Starter

    Joined:
    2010/01/27
    Messages:
    258
    Likes Received:
    1
    Trophy Points:
    233
    Computer Experience:
    Keeps getting better
    Since the upgrade to the site I have noticed that it is much less responsive than it used to be. This is particularly disturbing when typing something. There is a lengthy and very noticeable lag between pressing a key and seeing something appear on the screen. I didn't have this with the old site and I don't have it with any other site. It only occurs here. I don't know what causes it but if it could be fixed that would greatly improve my user experience.
     
  2. 2016/06/23
    retiredlearner

    retiredlearner SuperGeek WindowsBBS Team Member

    Joined:
    2004/06/25
    Messages:
    5,455
    Likes Received:
    295
    Trophy Points:
    1,093
    Location:
    New Zealand
    Computer Experience:
    intermediate
    No problem here. In fact it seems more responsive to me. I'm running W10 Pro 64bit and I have no slowness at all. Neil.
     

  3. to hide this advert.

  4. 2016/06/23
    Admin.

    Admin. Administrator Administrator Staff

    Joined:
    2001/12/30
    Messages:
    6,570
    Likes Received:
    82
    Trophy Points:
    743
    Location:
    Birkirkara, Malta
    Computer Experience:
    ***
    Sorry for your trouble. All I can suggest is that you try a different browser (you are using an outdated version of Chrome). The site is a magnitude faster than the old one.
     
  5. 2016/06/23
    rikki

    rikki Well-Known Member Thread Starter

    Joined:
    2010/01/27
    Messages:
    258
    Likes Received:
    1
    Trophy Points:
    233
    Computer Experience:
    Keeps getting better
    That's very odd. I have tried two browsers, both Chrome-based (Slimjet and Vivaldi). However it seems to be working better now. I wouldn't have mentioned it except I had the same issue twice on different days.
     
  6. 2016/06/23
    Admin.

    Admin. Administrator Administrator Staff

    Joined:
    2001/12/30
    Messages:
    6,570
    Likes Received:
    82
    Trophy Points:
    743
    Location:
    Birkirkara, Malta
    Computer Experience:
    ***
    retiredlearner is from your corner of the globe, he would know if there's been a problem with the site. I'm not aware of any recent troubles, but there always could have been some congestion 'en-route'...
     
  7. 2016/06/23
    TonyT

    TonyT SuperGeek Staff

    Joined:
    2002/01/18
    Messages:
    8,713
    Likes Received:
    365
    Trophy Points:
    1,093
    Location:
    Fairfax, VA
    Computer Experience:
    echo $experienced;
    Whenever you see a "slow" in a site loading or responding do a trace route.
    Open a command window and type:
    tracert www.<name-of-slow-site>.com

    You'll see a list of the routers and computers that the connection passes through en route. You'll see where the slow down occurs. If all of the "times" in milliseconds are good, meaning less than say 50, then the slow will be caused by something on your computer.

    The 3 top causes of "sites slow to load" are:
    1. browser addons and plugins.
    2. malware
    3. older browser versions.
     

Share This Page