1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. You are viewing our forum as a guest. For full access please Register. WindowsBBS.com is completely free, paid for by advertisers and donations.

Resolved HTTP port is disabled message

Discussion in 'Networking (Hardware & Software)' started by Bucksone, 2017/07/29.

  1. 2017/07/29
    Bucksone

    Bucksone Well-Known Member Thread Starter

    Joined:
    2003/07/28
    Messages:
    494
    Likes Received:
    2
    Trophy Points:
    233
    Location:
    Central Ohio, USA
    Computer Experience:
    Intermediate
    I'm trying to connect my Samsung Blu-ray player to my ASUS router. I'm doing a wired connection. I want to be able to watch Netflix shows through the player and also access home videos stored on my computer. After making the connection, I run a network test on the blu-ray player. It shows a check next to MAC Address, IP Address, Subnet Mask, Gateway, DNS Server, and Gateway Ping. It shows an X next to Internet Service Test and the following message is displayed. "The HTTP port is disabled. Please check if the HTTP port is blocked by something like the internal firewall program."
    I Googled this message and found lots of people complaining about getting this message with their Samsung player, but no solutions to help my problem. I thought I would post here as this forum has always been my go to place for solving these types of problems.
    The blu-ray player is a Samsung model BD-D5100. My router is an ASUS AC1900 Dual Band 802.11ac gigabit router.
    Thanks in advance for any assistance.
     
  2. 2017/07/29
    retiredlearner

    retiredlearner SuperGeek WindowsBBS Team Member

    Joined:
    2004/06/25
    Messages:
    5,462
    Likes Received:
    295
    Trophy Points:
    1,093
    Location:
    New Zealand
    Computer Experience:
    intermediate
    Firewall settings would need to be set to allow what you need through the firewall I think.
     

  3. to hide this advert.

  4. 2017/07/29
    TonyT

    TonyT SuperGeek Staff

    Joined:
    2002/01/18
    Messages:
    8,713
    Likes Received:
    365
    Trophy Points:
    1,093
    Location:
    Fairfax, VA
    Computer Experience:
    echo $experienced;
    Set the samsung player network manually:

    1. Give it a static IP address. If router address is 192.168.1.1 the give the samsung 192.168.1.250.
    2. Set subnet to 255.255.255.0.
    3. Set gateway to same as router IP (192.168.1.1)
    4. Set DNS to same as route IP (192.168.1.1)

    (corrected a typo)
     
    Last edited: 2017/08/01
  5. 2017/08/01
    Bucksone

    Bucksone Well-Known Member Thread Starter

    Joined:
    2003/07/28
    Messages:
    494
    Likes Received:
    2
    Trophy Points:
    233
    Location:
    Central Ohio, USA
    Computer Experience:
    Intermediate
    I followed TonyT's advice and got the same result. For steps 3 and 4 I used 168 for the middle digits. I assumed that the 169 noted above was just a typo.
     
  6. 2017/08/01
    TonyT

    TonyT SuperGeek Staff

    Joined:
    2002/01/18
    Messages:
    8,713
    Likes Received:
    365
    Trophy Points:
    1,093
    Location:
    Fairfax, VA
    Computer Experience:
    echo $experienced;
    Yes, use 168, not 169.
    The player will use the first entry for DNS and if it fails it will then not try the second DNS and it will throw out a "no Internet" message. Thus, instead of using the router IP for the player DNS use in this order if can enter 3: 8.8.8.8 + 8.8.4.4 + 192.168.1.1. (first 2 are google DNS) (also, wise to use those first 2 in router DNS settings too).

    Also, check the router Web interface firewall, it may be blocking the player erroneously.
     
    Last edited: 2017/08/01
  7. 2017/08/03
    Bucksone

    Bucksone Well-Known Member Thread Starter

    Joined:
    2003/07/28
    Messages:
    494
    Likes Received:
    2
    Trophy Points:
    233
    Location:
    Central Ohio, USA
    Computer Experience:
    Intermediate
    I tried to follow your instructions but no success yet. In the player settings there only appears to be one place to enter DNS number. I tried it with each of the numbers you suggested above but no luck. I don't know how to adjust the router DNS settings.
    I temporarily turned off the router's firewall and tried it, but no luck. I turned the router's firewall back on, of course. I also temporarily turned off the router's MAC address filtering to see if that would help, but no luck.
    Any more suggestions would be appreciated.
     
  8. 2017/08/03
    retiredlearner

    retiredlearner SuperGeek WindowsBBS Team Member

    Joined:
    2004/06/25
    Messages:
    5,462
    Likes Received:
    295
    Trophy Points:
    1,093
    Location:
    New Zealand
    Computer Experience:
    intermediate
  9. 2017/08/05
    Bucksone

    Bucksone Well-Known Member Thread Starter

    Joined:
    2003/07/28
    Messages:
    494
    Likes Received:
    2
    Trophy Points:
    233
    Location:
    Central Ohio, USA
    Computer Experience:
    Intermediate
    I followed the above instructions when first beginning this effort to connect the player to my computer. It didn't work. Hoping for some additional help. Thanks.
     
  10. 2017/08/05
    TonyT

    TonyT SuperGeek Staff

    Joined:
    2002/01/18
    Messages:
    8,713
    Likes Received:
    365
    Trophy Points:
    1,093
    Location:
    Fairfax, VA
    Computer Experience:
    echo $experienced;
    Per the research I've done the cause of the problem is the player's inability to resolve addresses, e.g. use a DNS server address. The solutions that worked for most folks has been to do a factory reset of the blue-ray player and then setup networking using a static address and google DNS (8.8.8.8).

    Note, if your router address is 192.168.1.1 then use an address for the player in that scheme. If your router is 192.168.0.1 then use that scheme. Set the player gateway to the same IP as router and subnet 255.255.255.0.

    Keep mac address filtering OFF in your router, you don't need that level of security.

    Once you get the player connect you should be able to access its control panel from a Web browser using its IP address. There may be more settings there that are not available on the tv screen.
     
  11. 2017/08/09
    Bucksone

    Bucksone Well-Known Member Thread Starter

    Joined:
    2003/07/28
    Messages:
    494
    Likes Received:
    2
    Trophy Points:
    233
    Location:
    Central Ohio, USA
    Computer Experience:
    Intermediate
    Victory!
    I did the factory reset, set up the network manually and it still didn't work. The gateway was wrong, I believe. Then I let it set up automatically, and it worked! I can now watch Netflix, and also access files on my computer as well using software called AllShare that Samsung provided the link to.
    Thanks for all of the help with this.
     
  12. 2017/08/10
    TonyT

    TonyT SuperGeek Staff

    Joined:
    2002/01/18
    Messages:
    8,713
    Likes Received:
    365
    Trophy Points:
    1,093
    Location:
    Fairfax, VA
    Computer Experience:
    echo $experienced;
    Well done!
     

Share This Page