Windows, Operating System, Security, Networking, Malware, Support, Forum, Help Site Check Our Facebook Page!
Notices
Windows XP Post your Windows XP related questions here.


Register your FREE account to unlock additional features at WindowsBBS.com
   
 
 
LinkBack Thread Tools
Old 25th February 2008   #1
Member
THREAD STARTER
 
Profile:
Join Date: Mar 2002
Posts: 7
Computer Experience:
intermediate
gleasonll Reputation Level

Remote Assistance Invitation Missing Public IP Address


I am trying to use Remote Assistance (RA) over the internet between 2 WinXP SP2 computers. Each computer is behind a NAT gateway/router, one UPnP (Linksys WCG200ver2) and the other non-UPnP:

pcA <---> UPnP NAT gateway <---> Internet <---> non-UPnP NAT gateway <---> pcB

QUESTION: why is the RA invitation generated on pcA not including the Public IP address of the gateway, even though the it is a UPnP enabled gateway. Without it, the connection will fail.

DETAILS:
UPnP NAT gateway (pcA) port forwarding of port 3389 to private IP of pcA.
Remote Assistance is enabled/allowed on both pcs (computer>properties>remote).
RA is allowed in Windows firewall on each pc. Windows firewall is disabled on each pc.
Remote Assistance exception, checked
Remote Assistance-Windows Messenger and Voice, checked
UPnP Framework, checked
Internet Gateway Device Discovery and Control Client is enabled (add or remove programs>add/remove windows components>components list>networking services>details)
SSDP Discovery Service is running on each pc.
an Internet Connection icon appears in "Network Connections"
UPnP Device Host Service is running on each pc.
a Broadband Router icon appears in "My Network Places"
Norton Internet Security 2008 on pcA: local port 1900/UDP open for UPnP Discovery (Shared Networks); local port 2869 open for SSDP (Shared Networks)


EMAIL Remote Assistance: If I generate a RA invitation on pcA (UPnP), the public IP of the gateway is not inserted into the invitation. I can establish a RA connection by editing the invitation, inserting the public IP address, and emailing it to pcB. When the invitaion on pcB is executed, a connection is established. The reverse is also works, from pcB to pcA.

WINDOWS MESSENGER Remote Assistance: a RA connection cannot be made in either direction using Win Msgr. Does this fail because the Public IP is not being supplied? What else should I try to correct this?

I have made successful RA connections, using Win Msgr, with several other computers (other than pcB). Is this because they are behind UPnP NAT devices and their Public IP address is being supplied?

gleasonll is offline  

 

Register
to remove this ad.
 
 

Old 25th February 2008   #2
Staff
 
TonyT's Avatar
 
Profile:
Join Date: Jan 2002
Location: Fairfax, VA
Posts: 7,800
Computer Experience:
echo $experienced;
TonyT Reputation LevelTonyT Reputation LevelTonyT Reputation LevelTonyT Reputation LevelTonyT Reputation LevelTonyT Reputation LevelTonyT Reputation LevelTonyT Reputation LevelTonyT Reputation LevelTonyT Reputation LevelTonyT Reputation Level

My System
You will probably need to setup port forwarding on the routers, forward port 3389. Then verify the software firewall allows the clients.

TonyT is offline  

Did you find this post helpful? Yes | No
Old 25th February 2008   #3
Member
THREAD STARTER
 
Profile:
Join Date: Mar 2002
Posts: 7
Computer Experience:
intermediate
gleasonll Reputation Level

Originally Posted by TonyT View Post
You will probably need to setup port forwarding on the routers, forward port 3389. Then verify the software firewall allows the clients.
Port 3389 is forwarded on the router/gateway (1st line under "Details").
The RA connection can be made successfully if I insert the Public IP of the router into the invitation. WinMsgr also works on with some computers. So, I believe the software firewall does allow the clients.

Is there anything else that should be checked to insure that the pcA gateway (UPnP) will insert the Public IP into the invitation, as it should if UPnP is working correctly?

gleasonll is offline  

Did you find this post helpful? Yes | No


 

THIS THREAD HAS EXPIRED.

Are you having the same problem? Please post a new thread, but first you'll have to join us by Registering (FREE).



Discussion Forums
Operating Systems
Windows 8 Windows 8
Windows 7 Windows 7
Windows Vista Windows Vista
Windows XP Windows XP
Windows Server System Windows Server System
Legacy Windows OS Legacy Windows OS
Internet & Networking
Networking (Hardware & Software) Networking
Internet Explorer Internet Explorer
Microsoft Mail Microsoft Mail
Firefox, Thunderbird & SeaMonkey Firefox, Thunderbird
      & SeaMonkey

Web Applications & Cloud Web Applications & Cloud
General Internet
Security
Malware and Virus Removal Malware and Virus
     Removal

Security and Privacy Security and Privacy

Other
Other PC Software Other PC Software
Test Posts Test Posts
Hardware
PC Hardware PC Hardware
Mobile Devices Mobile Devices
Community
Introductions Introductions
General Discussions General Discussions
Site Comments & Suggestions Site Comments
      & Suggestions

News News @ WindowsBBS

Thread Tools


Find us on Facebook   Web Of Trust Rating

All times are GMT. The time now is 00:23.


Recent Discussions
Invalid IP address error, fixed but.. (1)
[Cannot open Standard User, open wo.. (1)
[Which] windows server 2012 edition.. (1)
Impact of defrag command on SSD? (2)
Excel Macro help (2)
What is giveio.sys and how to get r.. (31)
Need shortcut/hotkey for MSDOS and .. (3)
My Passport Back Up and Remove data (2)
Brother QL500 labelmaker (3)
Extremely Slow File moving/copying/.. (10)
How do I stop Windows Explorer pers.. (8)
Microsoft July 2014 Security Bullet.. (1)
Microsoft August 2014 Security Bull.. (1)
IE slowed by latest updates. Fix av.. (0)
Latest MS patch causing BSOD (10)
Cannot mount Seagate to Router (13)
Proxy server on this computer (6)
Wrong CPU Installing (14)
BSoD (44)
Upgrading to Windows 8.1 can mean l.. (20)


Donate!
Support Windows BBS!



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO
Copyright 2002 - 2013 WindowsBBS.com. All rights reserved.
FDMA Media LLC
Terms of Use, Legal Information & Privacy Policy
Page generated in 0.07040 seconds with 7 queries