Windows, Operating System, Security, Networking, Malware, Support, Forum, Help Site Check Our Facebook Page!
Notices
Windows XP Post your Windows XP related questions here.


Register your FREE account to unlock additional features at WindowsBBS.com
   
 
 
LinkBack Thread Tools
Old 22nd May 2006   #1
Inactive
THREAD STARTER
 
Profile:
Join Date: Jan 2003
Location: Scotland
Posts: 84
Computer Experience:
intermediate
darich is infamous around these parts

Send a message via AIM to darich Send a message via Yahoo to darich

USB drive not visible in "My Computer"


I recently bought a usb flash drive for trasnferring files. It works a treat at work and i can listen to mp3s and check all sorts of other files in the office.

I'm now at home and my pc doesn't see the flash drive. The odd thing is, it did at first to load the mp3s onto the drive. On my taskbar next to the clock i have the "Safely Remove Hardware" icon so the pc knows it's connected but there is no drive shown when i go to "my computer"
The usb drive knows it's connected because the led flashes for a few secs then stays lit.

I've tried re-booting with the drive connected, re-booting with the drive not connected and I've even tried changing the letters of my existing hard drives (2 HDDs, C drive and D, E, F) I've got a CD reWriter and a DVD reWriter as H and I.

Nothing I've tried so far has made the drive show up. I'm stuck!!

Any thoughts anyone???

many thanks
David

darich is offline  

 

Register
to remove this ad.
 
 

Old 22nd May 2006   #2
Staff
 
PeteC's Avatar
 
Profile:
Join Date: May 2002
Location: Staffordshire, UK
Posts: 27,732
Computer Experience:
Usually not enough
PeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation Level

My System
David

A couple of possible solutions ....

Right click on My Computer > Manage > Disk Management - is the drive recognised? If so right click on the drive > Change drive letter or paths and choose an unused drive letter > OK

or

Use Tweakui to check that the drive is not hidden.

PeteC is online now  

Did you find this post helpful? Yes | No
Old 22nd May 2006   #3
Inactive
 
Profile:
Join Date: May 2006
Posts: 19
Computer Experience:
Experienced
capone Reputation Level

May need drivers, check the event logs.

capone is offline  

Did you find this post helpful? Yes | No
Old 22nd May 2006   #4
Staff
 
PeteC's Avatar
 
Profile:
Join Date: May 2002
Location: Staffordshire, UK
Posts: 27,732
Computer Experience:
Usually not enough
PeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation Level

My System
Quote:
May need drivers, check the event logs.
Not for XP - yes for 98.

PeteC is online now  

Did you find this post helpful? Yes | No
Old 22nd May 2006   #5
Inactive
THREAD STARTER
 
Profile:
Join Date: Jan 2003
Location: Scotland
Posts: 84
Computer Experience:
intermediate
darich is infamous around these parts

Send a message via AIM to darich Send a message via Yahoo to darich
Originally Posted by PeteC
David

A couple of possible solutions ....

Right click on My Computer > Manage > Disk Management - is the drive recognised? If so right click on the drive > Change drive letter or paths and choose an unused drive letter > OK

or

Use Tweakui to check that the drive is not hidden.
Excellent!!
It was recognised in disk management so i assigned it letter Q. No change. I tried TweakUI (I already have it installed) and ticked every box so all drives would be displayed and it popped up.

Thanks a million!!
Cheers!

darich is offline  

Did you find this post helpful? Yes | No
Old 22nd May 2006   #6
Staff
 
PeteC's Avatar
 
Profile:
Join Date: May 2002
Location: Staffordshire, UK
Posts: 27,732
Computer Experience:
Usually not enough
PeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation Level

My System
You're welcome - I just love the simple solutions

PeteC is online now  

Did you find this post helpful? Yes | No
Old 28th May 2006   #7
Senior Member
Lifetime Subscription
 
Profile:
Join Date: Jan 2002
Location: USA
Posts: 459
Computer Experience:
Intermediate
pilotgal8 Reputation Level

Well this solutions didn't work for me. I have a travel drive that is recognized when I plug into the USB port on the rear of the new case (or a USB extension cord plugged into the rear USB on the case).

HOWEVER.... It's not recognized whne plugged into either of the front case USB's. Have rechecked the wiring on the new case & all seems OK. When travel drive plugged into the fornt USB the 'unplug/eject hardware' icon appears on the systray & shows a USB device with the yellow "!". Properties show code 28 driver not installed

MyComputer/Management/Disk mgmt only shows the 3 hardfiles C D & E & the 2 CDROM's F&G

HOWEVER Explorer shows C D E & F yet G shows as a zip 100 icon yet type = CDROM (not sure any of that is relevant but......)
Device Mgr shows
SiS 7001 PCI to USB OPEn Host Ctrlr
SiS 7001 PCI to USB OPEn Host Ctrlr
SiS 7002 USB 2.0 Enhanced Host Ctrlr
USB 2.0 Root Hub
USB Root Hub
USB Root Hub
USB Device with the yellow !


TIA for any help.

pilotgal8 is offline  

Did you find this post helpful? Yes | No
Old 28th May 2006   #8
Staff
 
PeteC's Avatar
 
Profile:
Join Date: May 2002
Location: Staffordshire, UK
Posts: 27,732
Computer Experience:
Usually not enough
PeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation Level

My System
pilotgal

Double check the wiring - good idea to pull the plugs from the motherboard and start over if they are separate plugs - one for each wire rather than a multiple moulded plug. Try another header if one is available on the board.

If the problem remains remove the "USB Device with the yellow !" through Device Manager and reboot to allow Windows to reinstall it.

Front ports do not work with all USB devices - something to do with the rear ports being hardwired and the front ports soft wired. However a pen drive should work fine on the front ports.

PeteC is online now  

Did you find this post helpful? Yes | No
Old 29th May 2006   #9
Senior Member
Lifetime Subscription
 
Profile:
Join Date: Jan 2002
Location: USA
Posts: 459
Computer Experience:
Intermediate
pilotgal8 Reputation Level

OOPPS, just realized this is in the WINXP thread & I'm running W2KPRO

pilotgal8 is offline  

Did you find this post helpful? Yes | No
Old 29th May 2006   #10
Staff
 
PeteC's Avatar
 
Profile:
Join Date: May 2002
Location: Staffordshire, UK
Posts: 27,732
Computer Experience:
Usually not enough
PeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation LevelPeteC Reputation Level

My System
OK, but my advice remains the same

PeteC is online now  

Did you find this post helpful? Yes | No


 

THIS THREAD HAS EXPIRED.

Are you having the same problem? Please post a new thread, but first you'll have to join us by Registering (FREE).



Discussion Forums
Operating Systems
Windows 8 Windows 8
Windows 7 Windows 7
Windows Vista Windows Vista
Windows XP Windows XP
Windows Server System Windows Server System
Legacy Windows OS Legacy Windows OS
Internet & Networking
Networking (Hardware & Software) Networking
Internet Explorer Internet Explorer
Microsoft Mail Microsoft Mail
Firefox, Thunderbird & SeaMonkey Firefox, Thunderbird
      & SeaMonkey

Web Applications & Cloud Web Applications & Cloud
General Internet
Security
Malware and Virus Removal Malware and Virus
     Removal

Security and Privacy Security and Privacy

Other
Other PC Software Other PC Software
Test Posts Test Posts
Hardware
PC Hardware PC Hardware
Mobile Devices Mobile Devices
Community
Introductions Introductions
General Discussions General Discussions
Site Comments & Suggestions Site Comments
      & Suggestions

News News @ WindowsBBS

Thread Tools


Find us on Facebook   Web Of Trust Rating

All times are GMT. The time now is 17:54.


Recent Discussions
Can't get Win7 shortcuts to open in.. (13)
Changing default View Fields in Out.. (3)
Dell Studio 540 350watt psu require.. (25)
Firefox and Thunderbird Version 31... (3)
How do I check links in favorites t.. (3)
CD player application (3)
Re-starting IE8 every time I change.. (1)
Battery available (free) for Arris .. (0)
Weather station software. (5)
Windows Update Failure (3)
Any advice on an iPhone? (1)
Need digital clock for comp that I .. (4)
Sound goes AWOL (6)
Need good replacement for Wordpad i.. (2)
Eliminating setpoint32.exe error (10)
xpwin grid limited width (10)
Computer (XP) freezes when click on.. (9)
I moved my pictures to a 68gb thum .. (11)
Internet conniction keeps going awa.. (4)
Device Can't Start (Teredo Tunnelin.. (5)


Donate!
Support Windows BBS!



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO
Copyright 2002 - 2013 WindowsBBS.com. All rights reserved.
FDMA Media LLC
Terms of Use, Legal Information & Privacy Policy
Page generated in 0.11046 seconds with 7 queries