Windows, Operating System, Security, Networking, Malware, Support, Forum, Help Site Check Our Facebook Page!
Notices
Firefox, Thunderbird & SeaMonkey Post your questions about Mozilla based products (Firefox, Thunderbird & SeaMonkey) here.


Register your FREE account to unlock additional features at WindowsBBS.com
   
 
 
LinkBack Thread Tools
Old 26th May 2006   #1
Inactive
THREAD STARTER
 
Profile:
Join Date: Oct 2004
Location: Canada, Eh!
Posts: 21
Computer Experience:
Expert Geek
Kazper Reputation Level

Send a message via ICQ to Kazper

Copy/Paste Broken in Firefox


Greetings!

Iím having a Copy/Paste problem on my Windows XP Home system that only seems to be effecting Firefox.

Hereís what happens...Letís say I copy a URL from a text document using Notepad, then start Firefox and paste the URL it works fine. If I just start Firefox, type something into the address bar select it, then copy it, itís on the clipboard. However, as soon as I visit a web page...any web page, the clipboard is no longer functional within Firefox. I can not copy anything from within Firefox. However, I can go out of Firefox to a different application, copy something, then go back into Firefox and paste. But, as soon as I visit another web page, the clipboard is erased and Iím back to where I started.

I am running the latest version of Firefox and even tried uninstalling all of my extensions and reinstalling Firefox, but that doesnít seem to fix the problem.

For security Iím running Zone Alarm and scan my system daily. I also performed scans with AdAware and Spybot. Everything there seems to be clean.

Also, Iíve tried copying/pasting with <CTRL><C> and <CTRL><V> as well as with the right mouse button, but that doesnít make a difference.

Basically, once I go to a web page nothing from within Firefox will copy to the clipboard until I quit and restart the browser.

One more thing. If I mouse-over the little icon on the left of a URL in the address bar it turns to the hand. I used to be able to drag & drop this to the desktop to create a shortcut to that URL. That is no longer working either.

Any help would be greatly appreciated.

Thanks!

Brian

Kazper is offline  

 

Register
to remove this ad.
 
 

Old 26th May 2006   #2
Alumni
 
Westside's Avatar
 
Profile:
Join Date: Mar 2003
Location: Omaha,NE
Posts: 4,506
Computer Experience:
Intermediate
Westside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation Level

My System
Which version Firefox? I happen to be wandering around, and use the very latest FF3.0a1 nightly, and I can drag and drop the URL as a link on the desktop. In all honesty, I am totally ignorant about any clipboard, but I can copy and paste, at will. And, this has happened with FF1.0.8 and 1.5.0.3.

Westside is offline  

Did you find this post helpful? Yes | No
Old 26th May 2006   #3
Senior Member
 
Profile:
Join Date: Jan 2002
Location: Sydney, NSW, Australia
Posts: 396
Computer Experience:
Experienced
Antony Reputation Level

My System
Originally Posted by Kazper
Hereís what happens...Letís say I copy a URL from a text document using Notepad, then start Firefox and paste the URL it works fine. If I just start Firefox, type something into the address bar select it, then copy it, itís on the clipboard. However, as soon as I visit a web page...any web page, the clipboard is no longer functional within Firefox. I can not copy anything from within Firefox. However, I can go out of Firefox to a different application, copy something, then go back into Firefox and paste. But, as soon as I visit another web page, the clipboard is erased and Iím back to where I started.
Could that be just one or few particular websites that disables Ctrl key?

Originally Posted by Kazper
I am running the latest version of Firefox and even tried uninstalling all of my extensions and reinstalling Firefox, but that doesnít seem to fix the problem.
Try create a new profile in Firefox, and see if that helps.

Antony is offline  

Did you find this post helpful? Yes | No
Old 26th May 2006   #4
Alumni
 
Ramona's Avatar
 
Profile:
Join Date: Dec 2001
Location: Missouri
Posts: 7,481
Computer Experience:
Experienced Learner
Ramona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation Level

My System

Welcome to the Forum, Kazper!


Kazper,

The Firefox copy/paste failure has been traced to a piece of junkware called New.net (NewDotNet) which is being bundled out with a lot of genuine applications at the moment, and installs itself in Firefox as if it were an extension.

Symptoms include the copy/paste buttons being grayed out on the context menu and the clipbord being cleared when attempting to copy between tabs or Firefox windows.

To remove new.net you must use the Add/Remove programs feature in Control Panel, or using its own uninstaller if it has been kind enough to leave one lying around, or via
Uninstalling NewDotNet http://www.newdotnet.com/removal.html or by downloading and running MS Antispyware and removing anything it recommends to do with new.net

Do not bother attempting to remove via Firefox, it does no good.

There is a comprehensive report on New.net on this site:
http://www.cexx.org/newnet.htm

If you don't have NewDotNet, then use the Firefox Standard Diagnostic: http://kb.mozillazine.org/Standard_diagnostic_(Firefox)

Ramona is offline  

Did you find this post helpful? Yes | No
Old 26th May 2006   #5
Alumni
Lifetime Subscription
 
JSS3rd's Avatar
 
Profile:
Join Date: Jun 2002
Location: Long Island
Posts: 2,077
Computer Experience:
??? Ohhh, yeahhh!!
JSS3rd Reputation LevelJSS3rd Reputation LevelJSS3rd Reputation LevelJSS3rd Reputation LevelJSS3rd Reputation LevelJSS3rd Reputation LevelJSS3rd Reputation LevelJSS3rd Reputation LevelJSS3rd Reputation Level

My System
Hi Kazper,

It sounds as though Ramona may have the answer, but I'm wondering ... do you use a clipboard manager/extender? Windows actually has (if I remember correctly) something like 256 clipboards, but only one is normally accessible by Windows, and only the last item copied or cut is available from it.

A clipboard manager/extender provides access to those other clipboards, but it may be easier to think in terms of a cache, from which any item copied or cut over a period of time can be recalled.

Numerous such programs are available, but two freeware ones are Clipboard Magic and YC3 (formerly Yankee Clipper). You might give one of them a try; it won't solve your problem, but it might make it easier to deal with.

JSS3rd is offline  

Did you find this post helpful? Yes | No
Old 29th May 2006   #6
Inactive
 
Profile:
Join Date: May 2006
Location: Central Arkansas
Posts: 2
Computer Experience:
Experienced
lsippell Reputation Level

My System

Same problem in Netscape


I have the exact same problem in Netscape 7.2 (except the copy and paste buttons are not grayed out, just don't work) but can not find any sign of New.net (NewDoNet) any were on my computer. I have been fighting this for two weeks and am not only stumped, but going crazy!


Louis

lsippell is offline  

Did you find this post helpful? Yes | No
Old 30th May 2006   #7
Alumni
 
Ramona's Avatar
 
Profile:
Join Date: Dec 2001
Location: Missouri
Posts: 7,481
Computer Experience:
Experienced Learner
Ramona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation Level

My System

Welcome to the Forum, lsippel!


Louis,

If you don't have new.net, then go through the steps in the Firefox Diagnostics:
http://kb.mozillazine.org/Standard_diagnostic_(Firefox

Ramona is offline  

Did you find this post helpful? Yes | No
Old 30th May 2006   #8
Alumni
 
Westside's Avatar
 
Profile:
Join Date: Mar 2003
Location: Omaha,NE
Posts: 4,506
Computer Experience:
Intermediate
Westside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation LevelWestside Reputation Level

My System
Louis,
since you say that your problems are in Netscape7.2, I am not sure if the
Diagnostics for Firefox will help, unless you can adapt them to NS7.2.
Typically, some weirdness appears if themes other than the standard ones are used. So, the test is to go to View|select a theme like Modern, ok, and restart browser.There may be extention's problems as well.
As a last resort, creation of a new profile is not a bad idea.
How have you been fighting the problem?

Westside is offline  

Did you find this post helpful? Yes | No
Old 30th May 2006   #9
Alumni
 
Ramona's Avatar
 
Profile:
Join Date: Dec 2001
Location: Missouri
Posts: 7,481
Computer Experience:
Experienced Learner
Ramona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation LevelRamona Reputation Level

My System
Louis,

Apologies, and by all means follow Westside's advice. Should never answer posts after midnight...

If Westside's suggestions don't stop the problem, then before creating a new Profile, try adding these two lines to your prefs.js file:
user_pref("capability.policy.default.Clipboard.cut copy", "allAccess");
user_pref("capability.policy.default.Clipboard.paste", "allAccess");

Close Netscape before making this edit. Open WordPad, then click on:
File | Open. Now navigate to the prefs.js file located here:
C:\Documents and Settings\user_name\Application Data\Mozilla\Profiles\profilename\xxxxxxxx.slt
Add the lines to the bottom of the list of scripts, and leave one blank space.

If still no joy, then start with Spy-bot Search&Destroy, or Lavasoft - Ad-Aware see if they find anything.

Let us know the results...

Ramona is offline  

Did you find this post helpful? Yes | No
Old 30th May 2006   #10
Banned
 
Profile:
Join Date: May 2006
Location: Minnesota.
Posts: 39
Computer Experience:
Intermediate
error Reputation Level

Send a message via AIM to error Send a message via MSN to error Send a message via Yahoo to error
I Had the same Problem Like this once....All I did Was Re Install Firefox And It worked.

error is offline  

Did you find this post helpful? Yes | No


 

THIS THREAD HAS EXPIRED.

Are you having the same problem? Please post a new thread, but first you'll have to join us by Registering (FREE).



Discussion Forums
Operating Systems
Windows 8 Windows 8
Windows 7 Windows 7
Windows Vista Windows Vista
Windows XP Windows XP
Windows Server System Windows Server System
Legacy Windows OS Legacy Windows OS
Internet & Networking
Networking (Hardware & Software) Networking
Internet Explorer Internet Explorer
Microsoft Mail Microsoft Mail
Firefox, Thunderbird & SeaMonkey Firefox, Thunderbird
      & SeaMonkey

Web Applications & Cloud Web Applications & Cloud
General Internet
Security
Malware and Virus Removal Malware and Virus
     Removal

Security and Privacy Security and Privacy

Other
Other PC Software Other PC Software
Test Posts Test Posts
Hardware
PC Hardware PC Hardware
Mobile Devices Mobile Devices
Community
Introductions Introductions
General Discussions General Discussions
Site Comments & Suggestions Site Comments
      & Suggestions

News News @ WindowsBBS

Thread Tools


Find us on Facebook   Web Of Trust Rating

All times are GMT. The time now is 06:16.


Recent Discussions
Invalid IP address error, fixed but.. (1)
[Cannot open Standard User, open wo.. (1)
[Which] windows server 2012 edition.. (1)
Impact of defrag command on SSD? (2)
Excel Macro help (2)
What is giveio.sys and how to get r.. (31)
Need shortcut/hotkey for MSDOS and .. (3)
My Passport Back Up and Remove data (2)
Brother QL500 labelmaker (3)
Extremely Slow File moving/copying/.. (10)
How do I stop Windows Explorer pers.. (8)
Microsoft July 2014 Security Bullet.. (1)
Microsoft August 2014 Security Bull.. (1)
IE slowed by latest updates. Fix av.. (0)
Latest MS patch causing BSOD (10)
Cannot mount Seagate to Router (13)
Proxy server on this computer (6)
Wrong CPU Installing (14)
BSoD (44)
Upgrading to Windows 8.1 can mean l.. (20)


Donate!
Support Windows BBS!



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO
Copyright © 2002 - 2013 WindowsBBS.com. All rights reserved.
FDMA Media LLC
Terms of Use, Legal Information & Privacy Policy
Page generated in 0.12953 seconds with 7 queries